Throttle hang up

Charles Scappaticci scapco at
Fri Oct 25 12:58:24 PDT 2013

It's gotta be a leak somewhere or your cable is hanging up somewhere.  I'm
betting on the vacuum leak.

Charles S.

On Sun, Oct 20, 2013 at 5:19 PM, schnowz <schnowz at> wrote:

> My throttle keeps hanging at 3,000 rpm and will normally return to idle
> after about 5 secs, The time varies though -sometimes longer. I did check
> for an air leak in the intake area (WD-40) but couldn't come up with
> anything conclusive. Took a trip up to New Hampshire last weekend to check
> out the fall colors and it was a little unnerving having zero engine
> braking going into a corner  -had to constantly hit the brakes.
> Any suggestions on what to check out. I havent tried spraying the hoses
> under the tank yet. The severity is getting worse and varies and it will
> sometimes come down if I blip the throttle -
> I'm hoping its not a diaphragm issue.
> Any thoughts welcome
> Pete S
> ______________________________________________________________________
> This is from the GPZList mailing list. GPZList at
> You subscribed to this mailing list. Therefore, you solicited all
> mail that you receive from this list. Therefore, ANY mail that you
> receive from this list is, by definition, NOT Spam, and if you report
> it as such, you are violating the terms of service.
> To unsubscribe, you may send email to gpzlist-unsubscribe at
> ______________________________________________________________________
> Unsubscribe or choose new options at
> You are subscribed at the email address SCAPCO at
> ______________________________________________________________________

More information about the GPZList mailing list