My SV died. FI light blinking.

Jo Rhett jorhett at fastlizardracing.com
Mon Sep 15 09:27:54 PDT 2008


This happened to me with my '05 on the racetrack :-(  Turned out to be  
the ignition relay.  There is a little connector just under your seat  
on the left hand side.  It had gotten trapped and pulled just barely  
apart by the rear fairing.  Pushing it back together solved the problem.

There's some silicon on that now ;-)

On Sep 13, 2008, at 9:21 PM, David Chamberlin wrote:
> Sigh.  After all this time telling people how bullet-proof and  
> reliable my
> SV is, it up and died on me tonight.  :-(
>
> It was running beautifully, I was just accelerating away from a stop  
> light
> and it suddenly died.  No sputtering, no hesitation, just *poof* done.
>
> I pulled over to the side and tried to restart it, it cranked fine,  
> but it
> didn't catch and the red FI light was blinking and it was flashing  
> FI in the
> LCD.  I'm going to go out on a limb here and say I think maybe it has
> something to do with the fuel system.  :-)  Oh, and to answer the  
> obvious,
> there should be a reasonable amount of fuel in there (and the fuel  
> light was
> not on).
>
> I tell ya - 3 miles of non-flat terrain is a lot farther than you  
> think when
> pushing a bike.  :-(  I think I got my workout for the month.  At  
> least it
> was night-time and not too warm.
>
> So - any ideas of what I should check/try to try and narrow it  
> down?  Or
> should I suck it up and find someone to help me tow it to a shop?
>
> Thanks,
> Dave

-- 
Jo Rhett /  velociRaptor Racing
#553 WERA / AFM







More information about the SV650 mailing list