2nd gen, no fuel pressure - fast ticking from small black box.

zoran zv30 at sbcglobal.net
Wed Oct 6 16:16:04 PDT 2010


It is relay. Wack it few times :)


Thanks

Zoran Vujasinovic
Twin Works Factory
775-786-4881
www.twfracing.com

----- Original Message ----- 
From: "Jo Rhett" <jorhett at fastlizardracing.com>
To: "Suzuki SV650 Mailing List" <sv650 at micapeak.com>
Sent: Wednesday, October 06, 2010 3:08 PM
Subject: Re: 2nd gen, no fuel pressure - fast ticking from small black box.


I just used the battery to start my other bike?  Looks good to me, battery 
tender doesn't complain about it either.  But I'll try swapping in a 
different battery.

Is that piece that is clicking the fuel pump relay, or is it trying to 
ignite the fuel pump relay?  What might be failing?

On Oct 5, 2010, at 10:58 PM, zoran wrote:
> Fuel pump relay. I think your battery is done.
>
> Thanks
>
> Zoran Vujasinovic
> Twin Works Factory
> 775-786-4881
> www.twfracing.com
>
> ----- Original Message ----- From: "Jo Rhett" 
> <jorhett at fastlizardracing.com>
> To: "Suzuki SV650 Mailing List" <sv650 at micapeak.com>
> Sent: Tuesday, October 05, 2010 10:54 PM
> Subject: 2nd gen, no fuel pressure - fast ticking from small black box.
>
>
> I just started to clean up the bikes and make sure everything is ready for 
> next month (had 3 month downtime due to surgery) and I noticed the 
> superstock '05 battery was dead.  I recharged it last night.  Today the 
> battery is fully charged, but when I turn on the kill switch I don't hear 
> the fuel injectors pressurize -- and I do get a fast clicking sound.
>
> Tracing the sound I found it coming from a small black box just behind the 
> battery on rider's right.  It's mounted with a suzuki rubber holder.  The 
> cabling and mount look stock to me.
>
> Checking my manuals hasn't clued me in.  I'm digging through the fische 
> and not having luck there either.  Anyone know what this box does?  Is it 
> likely this box is dead, or more likely that it's trying to fire up 
> something else which is dead or possibly disconnected by accident when I 
> was cleaning up?
>
> -- 
> Jo Rhett /  velociRaptor Racing
> #553 WERA
>

-- 
Jo Rhett /  velociRaptor Racing
#553 WERA



More information about the SV650 mailing list