Weak charging?

Steven Bixby steven at bixbys.net
Mon Mar 24 10:58:33 PDT 2008

So, my GPZ has been mostly unused recently and I brought it back to
life last week while my ST13 is being serviced (by me, over several

One issue I know I need to get after is to pull the carbs and look
them over; I am fairly sure that there is some idle-circut clogging
occurring as it hesitates very badly off-idle.  But that's besides the
current point.

The other issue that I'm concerned about is that I don't think the
charging system is getting much done - I suspect the battery isn't
getting charged.  The bike will run once I get it started but it
always seems to be weak on the restart and I've put the charger on to
take care of it a time or three.   I've bumped started it another time
or three in the past few days too.

So - how does one diagnose this?  I've never tried to check a charging
system before.   I have some measure of electrical know-how and can
drive a DVOM fairly well.  I suspect I need to get a shunt in-line so
I can check the current flow into/out of the battery, but if there's
some inexpensive diagnostic tools out there already, that'd be great.

If the alternator is headed south - is it difficult to replace?  Are
there other points of interest besides the alternator that would cause
poor charging?

BTW, the battery is about 6 months old, so I don't *think* it's the
problem spot.  Once I put it on the charger for 10 minutes or so it
usually spins the starter with great gusto, and there's enough voltage
to drive the spark.

More information about the GPZList mailing list